スポンサーサイト 

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

yumでTest::Harnessがエラーになる(Cent) 

ひさしぶりにyum updateした所、450程のパッケージ更新が行われた。 その後 Test::Harness がおかしくなった。

Can't use an undefined value as an ARRAY reference at /usr/lib/perl5/5.8.8/Test/Harness.pm line 373.

とエラーになった。CentのyumとPerlのCPANがそれぞれperlパッケージを管理しているのでバッティングしたのだと思う。Perlの側でTest::Harnessを更新する。

% su -
# perl -MCPAN -e shell

cpan shell -- CPAN exploration and modules installation (v1.7602)
ReadLine support enabled



cpan> install Test::Harness
(略)
Result: PASS
/usr/bin/make test -- OK
Running make install
Installing /usr/lib/perl5/5.8.8/Test/Harness.pm
Installing /usr/bin/prove
Writing /usr/lib/perl5/5.8.8/i386-linux-thread-multi/auto/Test/Harness/.packlist
Appending installation info to /usr/lib/perl5/5.8.8/i386-linux-thread-multi/perllocal.pod
/usr/bin/make install -- OK


cpan> exit
Lockfile removed.
# exit
%

直った。

コメント

コメントの投稿















管理者にだけ表示を許可する

トラックバック

この記事のトラックバックURL
http://haginov.blog35.fc2.com/tb.php/144-6c98e379

上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。